Wednesday, 9 June 2010

Scanners in Opensuse 11.2 (64 Bit)

For a while now I've been attempting on and off to get my flatbed scanner working in OpenSuSE versions. I've tried most versions from 11.0 to 11.2, but I always ran in to the same problem. The problem is that Yast tells me it will work on a 32Bit version of OpenSuSE, but not a 64 Bit version. I've got a "Epson Perfection 4490 Photo" flatbed scanner that I'm connecting via USB.

Last night I need to do some scanning and felt it was time to have another go and getting it working. Yast gave the same error message, so I though I'd check out the Epson website for drivers. First of their UK site was completly broken :-(, but their US site was working fine. I was surprised to find that their was drivers for Linux on their site!! How things have changed these days :-)

It turns out that the driver is a link to another site http://avasys.jp/eng/. This site seems todo quite a few drivers for Linux, amongst them are 64 Bit drivers for and instructions for my scanner. They also seem to have the source code on the site. It's quite possible that the OpenSuSE driver support for scanners could be improved by this.
Post a Comment